Opened 8 years ago

Closed 8 years ago

#360 closed defect (worksforme)

STORE command gives an "No error"-Error on Permission Problems

Reported by: stephanj Owned by:
Priority: medium Milestone:
Component: RoarAudio PlayList Daemon Version: 0.1.7
Keywords: Cc:
Architecture: amd64 Compiler: gcc/mingw
Difficulty: Kernel: Linux
Operating System: Debian Parent Tickets:
Patch attached: no Protocol: RPLD
Sound driver: Topic:

Description

I encountered this when RPLD had no write permissions to the store.

Subtickets

Change History (4)

comment:1 Changed 8 years ago by ph3-der-loewe

  • Summary changed from STORE command gives an Error(No error) on Permission Problems to STORE command gives an "No error"-Error on Permission Problems

I updated the topic as it seems this ticket is about the incorrect error message.

How I tried to reproduce it:

$ rpld-storemgr --store-path /tmp/STORE create
$ chmod -R a-w /tmp/STORE/
$ rpld-storemgr --store-path /tmp/STORE console
STORE
.
> 1 Error (Operation not permitted)

So this seems to be correct to me.
Can you please provide version of libroar?
On Debian: dpkg -l libroar\*
Generic: roar-config --version

comment:2 Changed 8 years ago by stephanj

Version is: 1.0~beta10-1

comment:3 Changed 8 years ago by ph3-der-loewe

There has been no related changes in libroar between my version and Debian's 1.0~beta10-1 as far as I can see. hm.

Can you reproduce the problem?

comment:4 Changed 8 years ago by ph3-der-loewe

  • Resolution set to worksforme
  • Status changed from new to closed

Ok, As nobody seems to be abled to reproduce the problem I close it now. stephan (the original reporter) confirmed me on IRC that it no longer happens to him.

Note: See TracTickets for help on using tickets.