Opened 8 years ago

Closed 6 years ago

#306 closed defect (worksforme)

Deadlock between roard and FLAC playing client should be avoided

Reported by: ph3-der-loewe Owned by: ph3-der-loewe
Priority: critical Milestone: RoarAudio major release 1.0
Component: roard Version: current
Keywords: FLAC deadlock Cc:
Architecture: Compiler:
Difficulty: very hard Kernel:
Operating System: Parent Tickets:
Patch attached: no Protocol:
Sound driver: Topic: Hardening

Description

Sometimes when a client plays a flac file roard gets into a deadlock because the client waits for roard to answer to some request while roard waits for the client on the data channel.

This seems to be this way because libFLAC seems not to support EAGAIN like events.

This should maybe be fixed in libFLAC.

Subtickets

Change History (5)

comment:1 Changed 7 years ago by ph3-der-loewe

libFLAC support has been disabled in 1.0beta6 when using --without-beta.

comment:2 Changed 7 years ago by ph3-der-loewe

A possible workaround would be to use pthreads just to allow safe context switching.

comment:3 Changed 7 years ago by ph3-der-loewe

  • Status changed from new to assigned

I'm going for the workaround now.
Already started with it.

comment:4 Changed 7 years ago by ph3-der-loewe

I can not reproduce this as it seems. Will try again tomorrow and close if unabled to do so.

comment:5 Changed 6 years ago by ph3-der-loewe

  • Resolution set to worksforme
  • Status changed from assigned to closed

To me it seems to work fine. Very strange error.
I close this ticket now but keep it in --without-beta. If someone can reproduce the problem please stand up and reopen this ticket.

Note: See TracTickets for help on using tickets.